Navigation: Technifree Vos commentaires et remarques Commentaires sur les logiciels Réserve sur Wamp.

Réserve sur Wamp.

Réserve sur Wamp.

 
  • Moyenne : 3.05 (164 vote(s))
 
JDG
Membre actif
77
15-05-2023, 09:17
#1
Bonjour
Désolé de plomber le coté "On cherche encore"  dans les défauts de Wamp. Pour ma part j'ai eu pas mal de soucis d'installation sur plusieurs Pc avec Win10 (Dll manquantes entre autre). Au point de laisser tomber , de chercher une alternative et de tomber sur Xamp... On ne change qu'une lettre mais ça change tout.

- Installation sans soucis sur chacun de mes Pc. (Win 10 et 11)
- multi-plateforme (Windows, Linux, Mac)
- choix des modules à installer ou  activer en plus du duo Apache/Mysql (Filezilla, Mercury Mail Server, Tomcat)
Voir la fiche Wikipedia. https://fr.wikipedia.org/wiki/XAMPP

Bref pour moi, la facilité va clairement vers Xamp.
JDG
Modification du message : 15-05-2023, 09:17 par JDG.

Plus j'avance et plus je m'aperçois que je ne sais rien. Et comme j'essaie sans cesse d'avancer .....    Souris
JDG
15-05-2023, 09:17 #1

Bonjour
Désolé de plomber le coté "On cherche encore"  dans les défauts de Wamp. Pour ma part j'ai eu pas mal de soucis d'installation sur plusieurs Pc avec Win10 (Dll manquantes entre autre). Au point de laisser tomber , de chercher une alternative et de tomber sur Xamp... On ne change qu'une lettre mais ça change tout.

- Installation sans soucis sur chacun de mes Pc. (Win 10 et 11)
- multi-plateforme (Windows, Linux, Mac)
- choix des modules à installer ou  activer en plus du duo Apache/Mysql (Filezilla, Mercury Mail Server, Tomcat)
Voir la fiche Wikipedia. https://fr.wikipedia.org/wiki/XAMPP

Bref pour moi, la facilité va clairement vers Xamp.
JDG


Plus j'avance et plus je m'aperçois que je ne sais rien. Et comme j'essaie sans cesse d'avancer .....    Souris

vincent
Administrateur
536
15-05-2023, 10:09
#2
Xamp est excellent, en effet ! Une fiche est prévue pour ce soft.
Étrange tes soucis de DLL, car  dans mes tests je n'ai pas rencontré ce soucis.
Est-ce récent ou plus ancien ? S'agit-il de la même version (branche 3.x) ?

Je sais qu'il y a des prérequis à respecter avant l'installation (chiants d'ailleurs). Je vais ajouter ça à "on aime moins", tu as raison Clin d'oeil
Pour info :
Citation :Installation de Wampserver
Si vous voulez éviter des problèmes, il faut impérativement lire la totalité de ce message.
AVANT de procéder à l'installation de Wampserver, vous devez vous assurez que certains éléments sont installés sur votre système, sinon, Wampserver ne pourra pas fonctionner, l'installation sera défectueuse et vous devrez supprimer Wampserver AVANT d'installer les éléments qui manquaient.
Les paquetages Microsoft Visual Studio VC9, VC10, VC11, VC15, VC17 et VS16 sont impérativement requis pour Wampserver 3 même si vous n'utilisez que des versions Apache et PHP VC11.
À la fin de ce texte, sous la rubrique --- Paquetages VC --- vous trouverez les liens de téléchargement desdits paquetages.
--- N'installez pas Wampserver PAR-DESSUS une version existante, suivez les conseils de :
- Installer une nouvelle version de Wampserver : http://forum.wampserver.com/read.php?1,119444
Si vous installez Wampserver par dessus une version existante, non seulement cela ne fonctionnera pas, mais en plus vous risquez de perdre vos bases de données existantes.
--- Installez Wampserver dans un dossier à la racine d'un disque, par exemple C:\wamp ou D:\wamp. Prenez un chemin d'installation qui ne comporte pas d'espaces ou de caractères diacritiques ; donc, pas d'installation dans c:\Program Files\ ou c:\Program Files (x86\
Il faut, AVANT l'installation, désactiver ou fermer certaines applications :
- Fermer Skype ou le forcer à ne pas utiliser le port 80
Item N°04 des CONSEILS DE DÉPANNAGE de Wampserver : http://forum.wampserver.com/read.php?1,88043
- Désactiver IIS
Item N°08 des CONSEILS DE DÉPANNAGE de Wampserver : http://forum.wampserver.com/read.php?1,88043
Si vous pensez ne pas être en accord avec ces prèrequis, validez Annuler pour annuler l'installation, appliquez les prérequis et relancez l'installation.

Ce programme nécessite des privilèges Administrateur pour fonctionner correctement. Il sera lancé avec l'option « Exécuter en tant qu'administrateur ». Si vous ne voulez pas qu'un programme ait cette option, annulez l'installation.
--- Paquetages VC ---
Vérifiez que vous êtes « à jour » dans les packages redistribuables VC9, VC10, VC11, VC13 et VC14
Même si vous pensez être à jour, installez en tant qu'administrateur et si message "Déjà installé", validez Réparer.
-- VC9 Paquetages (Visual Studio 2008 SP1)
http://www.microsoft.com/fr-fr/download/...px?id=5582
http://www.microsoft.com/fr-fr/download/...px?id=2092
-- VC10 Paquetages (Visual Studio 2010 SP1)
http://www.microsoft.com/fr-fr/download/...px?id=8328
http://www.microsoft.com/fr-fr/download/...x?id=13523
-- VC11 Paquetages (Visual Studio 2012 Update 4)
Les deux fichiers VSU4\vcredist_x86.exe et VSU4\vcredist_x64.exe à télécharger sont sur la même page : http://www.microsoft.com/fr-fr/download/...x?id=30679
-- VC13 Paquetages Update 5(Visual Studio 2013)
Les deux fichiers VSU4\vcredist_x86.exe et VSU4\vcredist_x64.exe à télécharger sont sur la même page :https://support.microsoft.com/en-us/help/4032938/
-- VC14 Paquetages (Visual Studio 2015 Update 3)Remplacé par VC15
-- VC15 Paquetages (VisualStudio 2017)Remplacé par VC16
-- VC16 Paquetages (VisualStudio 2015-2019) Remplacé par VC17
-- VC17 Paquetages (VisualStudio 2015-2022)
Visual C++ Redistributable Packages for Visual Studio 2015-2019 x86
https://aka.ms/vs/17/release/VC_redist.x86.exe
Visual C++ Redistributable Packages for Visual Studio 2015-2019 x64
https://aka.ms/vs/17/release/VC_redist.x64.exe
VC 2015-2022 (VC17) est rétrocompatible avec VC 2015 (VC14), VC 2017 (VC15) et VC 2019 (VC16). Cela signifie qu'un module VC14, VC15 ou VC16 peut être utilisé avec les binaires VC17. De par cette compatibilité, le numéro de version de Redistributable est 14.3x.xx et après l'installation, les paquetages Redistribuable VC2015 (VC14), VC2017 (VC15) et VC2019 (VC16) sont éventuellement supprimés mais vous pourrez toujours utiliser VC14, VC15 et VC16.

Si vous avez un Windows en 64 bits, il faut installer les deux versions 32 et 64bits de chaque paquetage VC, même si vous n'utilisez que Wampserver 32 bits.
Pour vérifier que tous les paquetages VC++ sont bien installés et avec les dernières versions, utilisez l'outil : http://wampserver.aviatechno.net/files/t...redist.exe et vous trouverez tous les paquetages sur http://wampserver.aviatechno.net/ dans la section Visual C++ Redistribuable Packages
N'utilisez pas une ancienne version de l'outil que vous auriez déjà téléchargé. Téléchargez toujours la dernière version juste avant de l'utiliser.
Voir item N°20 des CONSEILS DE DÉPANNAGE de Wampserver : http://forum.wampserver.com/read.php?1,88043

J'ai mis à jour la fiche en conséquence. Merci Clin d'oeil
vincent
15-05-2023, 10:09 #2

Xamp est excellent, en effet ! Une fiche est prévue pour ce soft.
Étrange tes soucis de DLL, car  dans mes tests je n'ai pas rencontré ce soucis.
Est-ce récent ou plus ancien ? S'agit-il de la même version (branche 3.x) ?

Je sais qu'il y a des prérequis à respecter avant l'installation (chiants d'ailleurs). Je vais ajouter ça à "on aime moins", tu as raison Clin d'oeil
Pour info :

Citation :Installation de Wampserver
Si vous voulez éviter des problèmes, il faut impérativement lire la totalité de ce message.
AVANT de procéder à l'installation de Wampserver, vous devez vous assurez que certains éléments sont installés sur votre système, sinon, Wampserver ne pourra pas fonctionner, l'installation sera défectueuse et vous devrez supprimer Wampserver AVANT d'installer les éléments qui manquaient.
Les paquetages Microsoft Visual Studio VC9, VC10, VC11, VC15, VC17 et VS16 sont impérativement requis pour Wampserver 3 même si vous n'utilisez que des versions Apache et PHP VC11.
À la fin de ce texte, sous la rubrique --- Paquetages VC --- vous trouverez les liens de téléchargement desdits paquetages.
--- N'installez pas Wampserver PAR-DESSUS une version existante, suivez les conseils de :
- Installer une nouvelle version de Wampserver : http://forum.wampserver.com/read.php?1,119444
Si vous installez Wampserver par dessus une version existante, non seulement cela ne fonctionnera pas, mais en plus vous risquez de perdre vos bases de données existantes.
--- Installez Wampserver dans un dossier à la racine d'un disque, par exemple C:\wamp ou D:\wamp. Prenez un chemin d'installation qui ne comporte pas d'espaces ou de caractères diacritiques ; donc, pas d'installation dans c:\Program Files\ ou c:\Program Files (x86\
Il faut, AVANT l'installation, désactiver ou fermer certaines applications :
- Fermer Skype ou le forcer à ne pas utiliser le port 80
Item N°04 des CONSEILS DE DÉPANNAGE de Wampserver : http://forum.wampserver.com/read.php?1,88043
- Désactiver IIS
Item N°08 des CONSEILS DE DÉPANNAGE de Wampserver : http://forum.wampserver.com/read.php?1,88043
Si vous pensez ne pas être en accord avec ces prèrequis, validez Annuler pour annuler l'installation, appliquez les prérequis et relancez l'installation.

Ce programme nécessite des privilèges Administrateur pour fonctionner correctement. Il sera lancé avec l'option « Exécuter en tant qu'administrateur ». Si vous ne voulez pas qu'un programme ait cette option, annulez l'installation.
--- Paquetages VC ---
Vérifiez que vous êtes « à jour » dans les packages redistribuables VC9, VC10, VC11, VC13 et VC14
Même si vous pensez être à jour, installez en tant qu'administrateur et si message "Déjà installé", validez Réparer.
-- VC9 Paquetages (Visual Studio 2008 SP1)
http://www.microsoft.com/fr-fr/download/...px?id=5582
http://www.microsoft.com/fr-fr/download/...px?id=2092
-- VC10 Paquetages (Visual Studio 2010 SP1)
http://www.microsoft.com/fr-fr/download/...px?id=8328
http://www.microsoft.com/fr-fr/download/...x?id=13523
-- VC11 Paquetages (Visual Studio 2012 Update 4)
Les deux fichiers VSU4\vcredist_x86.exe et VSU4\vcredist_x64.exe à télécharger sont sur la même page : http://www.microsoft.com/fr-fr/download/...x?id=30679
-- VC13 Paquetages Update 5(Visual Studio 2013)
Les deux fichiers VSU4\vcredist_x86.exe et VSU4\vcredist_x64.exe à télécharger sont sur la même page :https://support.microsoft.com/en-us/help/4032938/
-- VC14 Paquetages (Visual Studio 2015 Update 3)Remplacé par VC15
-- VC15 Paquetages (VisualStudio 2017)Remplacé par VC16
-- VC16 Paquetages (VisualStudio 2015-2019) Remplacé par VC17
-- VC17 Paquetages (VisualStudio 2015-2022)
Visual C++ Redistributable Packages for Visual Studio 2015-2019 x86
https://aka.ms/vs/17/release/VC_redist.x86.exe
Visual C++ Redistributable Packages for Visual Studio 2015-2019 x64
https://aka.ms/vs/17/release/VC_redist.x64.exe
VC 2015-2022 (VC17) est rétrocompatible avec VC 2015 (VC14), VC 2017 (VC15) et VC 2019 (VC16). Cela signifie qu'un module VC14, VC15 ou VC16 peut être utilisé avec les binaires VC17. De par cette compatibilité, le numéro de version de Redistributable est 14.3x.xx et après l'installation, les paquetages Redistribuable VC2015 (VC14), VC2017 (VC15) et VC2019 (VC16) sont éventuellement supprimés mais vous pourrez toujours utiliser VC14, VC15 et VC16.

Si vous avez un Windows en 64 bits, il faut installer les deux versions 32 et 64bits de chaque paquetage VC, même si vous n'utilisez que Wampserver 32 bits.
Pour vérifier que tous les paquetages VC++ sont bien installés et avec les dernières versions, utilisez l'outil : http://wampserver.aviatechno.net/files/t...redist.exe et vous trouverez tous les paquetages sur http://wampserver.aviatechno.net/ dans la section Visual C++ Redistribuable Packages
N'utilisez pas une ancienne version de l'outil que vous auriez déjà téléchargé. Téléchargez toujours la dernière version juste avant de l'utiliser.
Voir item N°20 des CONSEILS DE DÉPANNAGE de Wampserver : http://forum.wampserver.com/read.php?1,88043

J'ai mis à jour la fiche en conséquence. Merci Clin d'oeil

JDG
Membre actif
77
15-05-2023, 11:43
#3
Je suis passé à Xamp en début 2022. J'avais donc essayé d'installer la dernière version de Wamp à ce moment là.
Mais je ne suis pas le seul à avoir eu ces soucis. J'en ai vu passer pas mal sur les forums à cette période.

JDG

Plus j'avance et plus je m'aperçois que je ne sais rien. Et comme j'essaie sans cesse d'avancer .....    Souris
JDG
15-05-2023, 11:43 #3

Je suis passé à Xamp en début 2022. J'avais donc essayé d'installer la dernière version de Wamp à ce moment là.
Mais je ne suis pas le seul à avoir eu ces soucis. J'en ai vu passer pas mal sur les forums à cette période.

JDG


Plus j'avance et plus je m'aperçois que je ne sais rien. Et comme j'essaie sans cesse d'avancer .....    Souris

 
  • Moyenne : 3.05 (164 vote(s))
Utilisateur(s) parcourant ce sujet :
 1 visiteur(s)
Utilisateur(s) parcourant ce sujet :
 1 visiteur(s)